MS Teams Missing When Scheduling Shared Calendar

Incident Report for Greenhouse

Resolved

We've identified the cause of the issue preventing users from adding Microsoft Teams as a video conferencing option when scheduling interviews on shared calendars. The Outlook API response for shared mailboxes is not returning any video conferencing providers, which results in the Teams option not appearing.

At this time, it's unclear whether this reflects a change in how shared mailboxes are supported or if it is an unintended behavior. We recommend that affected customers work with their internal IT or Outlook support teams for further investigation.
Posted Sep 05, 2025 - 23:37 UTC

Identified

We are currently experiencing an issue with the Microsoft Teams integration that affects scheduling interviews on shared calendars. At this time, users are unable to select the Teams option when scheduling. Our Engineering team is actively investigating the root cause. We will continue to provide updates as more information becomes available.
Posted Sep 04, 2025 - 20:31 UTC
This incident affected: Third-Party Dependencies (Outlook 365).