Interseller errors

Incident Report for Greenhouse

Resolved

This incident has now been resolved. The email links in the previously received emails will now work as expected.
Posted Jul 14, 2025 - 17:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 17:11 UTC

Identified

Recipients of emails from Interseller or Greenhouse Sourcing Automation may be experiencing issues with the links in the email body. The links might be broken or appearing as coming from an unverified domain.
Posted Jul 14, 2025 - 16:50 UTC
This incident affected: Greenhouse Sourcing Automation and Interseller for Agencies.