Delays in Application Processing
Incident Report for Greenhouse
Resolved
This incident has been resolved. We apologize for the inconvenience this has caused.
Posted Sep 04, 2020 - 10:47 EDT
Monitoring
We have implemented a fix for this issue and all applications have now been processed. We are monitoring for any further issues.
Posted Sep 04, 2020 - 10:07 EDT
Identified
We are currently experiencing delays in applications appearing in the Candidates tab after they are submitted. We have identified the root cause of the issue and are working on a fix.
Posted Sep 04, 2020 - 09:51 EDT
This incident affected: Greenhouse Products (Greenhouse Recruiting).