Greenhouse Onboarding - Slowness with E-signature Requests
Incident Report for Greenhouse
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 19:18 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 30, 2019 - 15:29 EDT
Investigating
HelloSign, Greenhouse Onboarding's e-signature provider, is currently experiencing degraded service, which is causing slowness with our E-signature feature. HelloSign has identified the issue and is currently working on a fix.
Posted Oct 30, 2019 - 15:29 EDT
This incident affected: Greenhouse Products (Greenhouse Onboarding).