Slow application response times

Incident Report for Greenhouse

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 23:38 UTC

Monitoring

A fix has been implemented and response times have come back to normal. We are continuing to monitor.
Posted Sep 05, 2025 - 17:50 UTC

Identified

We are currently seeing increased HTTP response times and timeouts for application traffic. We've identified the cause and are actively working to resolve the issue.
Posted Sep 05, 2025 - 16:40 UTC
This incident affected: Greenhouse Onboarding.