Greenhouse Recruiting Outage
Incident Report for Greenhouse
Resolved
This incident has been resolved. We apologize for any inconvenience.
Posted 5 months ago. Apr 24, 2018 - 11:45 EDT
Monitoring
Greenhouse Recruiting was briefly inaccessible. The issue is resolved but we are monitoring for any further degradations.
Posted 5 months ago. Apr 24, 2018 - 11:35 EDT