Issues Logging into Greenhouse Recruiting
Incident Report for Greenhouse
Resolved
This incident has been resolved. We apologize for any inconvenience.
Posted 3 months ago. Jun 14, 2017 - 14:57 EDT
Identified
The issue has been identified and we are working to resolve it.
Posted 3 months ago. Jun 14, 2017 - 14:54 EDT
Investigating
We are receiving reports that some customers are having issues logging in to Greenhouse Recruiting and are investigating.
Posted 3 months ago. Jun 14, 2017 - 14:52 EDT