Greenhouse Recruiting Unavailable For Some Customers
Incident Report for Greenhouse
Resolved
Greenhouse Recruiting was unavailable between 6:01 and 6:06 PM EST.
Posted 10 days ago. Dec 06, 2018 - 21:10 EST
Monitoring
We are currently monitoring the issue.
Posted 10 days ago. Dec 06, 2018 - 18:11 EST
This incident affected: Greenhouse Products (Greenhouse Recruiting).