Issues loading www.greenhouse.io and support.greenhouse.io
Incident Report for Greenhouse
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 13:00 EST
Monitoring
We have implemented a fix and are monitoring for further issues.
Posted Feb 23, 2021 - 12:27 EST
Update
We are continuing to investigate issues loading www.greenhouse.io and support.greenhouse.io.
Posted Feb 23, 2021 - 12:10 EST
Investigating
We are investigating issues loading www.greenhouse.io and support.greenhouse.io.

If you are trying access Greenhouse Recruiting, you can still log in at app.greenhouse.io.
Posted Feb 23, 2021 - 11:31 EST
This incident affected: Greenhouse Website.