Harvest API Outage
Incident Report for Greenhouse
Postmortem

We upgraded a portion of our API’s framework yesterday at 10:55AM EDT. Some customers reported an elevated number of of HTTP Status 500 errors during this time until approximately 11:35AM EDT.

We actively monitor all releases, but due to the nature of this upgrade, our alert logs didn’t capture the errors that some customers were experiencing. We’ve identified this as a gap in the logging for our API and have modified our alerting logs to also include errors stemming from our API framework, allowing us to properly intercept and proactively correct these issues in the future.

Posted 6 months ago. Mar 20, 2018 - 13:34 EDT

Resolved
Our team has not identified any additional increase in errors from the Harvest API. We apologize for any inconvenience this issue has caused for you and your teams.
Posted 6 months ago. Mar 19, 2018 - 12:02 EDT
Monitoring
Our team has deployed a fix and the Harvest API is now responding normally. We will continue monitoring for any other disruptions.
Posted 6 months ago. Mar 19, 2018 - 11:45 EDT
Investigating
Our team has identified an issue with the Harvest API that is resulting in an increase in 500 errors for nearly all endpoints. We are currently working to resolve the issue.
Posted 6 months ago. Mar 19, 2018 - 11:42 EDT