Greenhouse Onboarding - Issues with E-signatures
Incident Report for Greenhouse
Resolved
This incident has been resolved. We apologize for any inconvenience.
Posted 10 days ago. Jan 08, 2018 - 20:19 EST
Monitoring
Our third-party e-signature provider is currently experiencing extensive delays in web and API response-times. We are working with them in any way we can to help improve the situation. You can follow their status updates here as well: https://status.hellosign.com/incidents/z7hg81m3wlnm
Posted 10 days ago. Jan 08, 2018 - 16:40 EST